Sentura Cloud - Billing Mailing Outage – Incident details

Billing Mailing Outage

Resolved
Operational
Started about 1 month agoLasted about 1 hour

Affected

sentura.cloud

Partial outage from 7:46 PM to 8:33 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved, you will now receive emails.

  • Identified
    Identified

    We are continuing to work on a fix for this incident, we have identified the root cause which is Google requiring verification for usage of some of their services.

  • Investigating
    Investigating

    We are currently investigating the root issue of this incident and our systems team is currently working on fixing the problem. You are still able to purchase items, however will not receive invoice emails, payment confirmation, etc.